iplounge.net Forum Index iplounge.net
NFS PU & HS Online Racing Community
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Fix Menu troubles
Goto page Previous  1, 2
 
Post new topic   Reply to topic    iplounge.net Forum Index -> IPL PU Support
View previous topic :: View next topic  
Author Message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Tue Dec 01, 2015 2:58 pm    Post subject: Reply with quote

I can't install it on any system, actually.

From this post: http://www.iplounge.net/forum/viewtopic.php?t=2370&start=45

I deduce that your complete patch was originally released with the SDB made with the previous version of ACT.
From the same post, Nath installed it on WinX but didn't solve his CTD problem.
So you rebuilt it with the new ACT.
Now, this new SDB, I can't install it.

I get the error on Windows XP x86, Windows 7 x64 and Windows 8.1 x64.
That's why I'm assuming the SDBs created for WinX are incompatible with older systems.

Did someone tried installing this SDB on Win7/8/XP or you all upgraded to WinX?
I don't think it's just a problem of mine because the Win8.1 and XP systems I tried installing it on are "fresh" systems, that is no PU installation never existed over them.
Back to top
View user's profile Send private message
Tuurngait



Joined: 07 Mar 2011
Posts: 299

PostPosted: Tue Dec 01, 2015 3:55 pm    Post subject: Reply with quote

Then make the test. Try the old ACT 5.6 version and the new 10.1 version and see if it works.
Back to top
View user's profile Send private message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Tue Dec 01, 2015 5:16 pm    Post subject: Reply with quote

Tuurngait wrote:
Try the old ACT 5.6 version and the new 10.1 version


I don't have the previous SDB, because the complete patch here: http://www.iplounge.net/forum/viewtopic.php?t=2370 has been updated with the new one.

Or you're referring to the ACT itself? The MS toolkit?
Back to top
View user's profile Send private message
Tuurngait



Joined: 07 Mar 2011
Posts: 299

PostPosted: Tue Dec 01, 2015 6:23 pm    Post subject: Reply with quote

Yes, with ACT I mean the MS toolkit. You can create your own sdb with this tool.
Back to top
View user's profile Send private message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Thu Dec 03, 2015 6:56 pm    Post subject: Reply with quote

Fresh news.

I installed ACT 5.6 and created a patch for porsche.exe, with compatibility to XP SP2 and with just the EmulateHeap fix.
Compiled the SDB and tried to install on Win7 x64, it works.

I installed ACT 6.1 from ADK-Win10 and created pretty the same patch, with compatibility to XP SP2 and with EmulateHeap active, plus other fixes it checked by default.
Compiled the SDB and tried to install on Win7 x64, it works.

So there should be something with your SDB that prevents me from installing it.
I'll investigate further.

Thanks, bb.

EDIT: I just tried to open your SDB with ACT and the Compatibility Administrator gives me the same error.
Thus, I suspect the file is damaged.
The size is reported to be 1762 bytes.
Can you please check this?

Thanks again for the support.
Back to top
View user's profile Send private message
Tuurngait



Joined: 07 Mar 2011
Posts: 299

PostPosted: Thu Dec 03, 2015 7:39 pm    Post subject: Reply with quote

Hmm, this is very strange. The file works for me as it should. I have ACT version 10.1

Back to top
View user's profile Send private message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Fri Dec 04, 2015 10:20 am    Post subject: Reply with quote

lol
increasingly intriguing...

Where did you download that version from?!?
I thought to have downloaded the latest version but it says it's 6.1.

From here: https://www.microsoft.com/en-us/download/details.aspx?id=7352 I expanded the "Related Resources" and clicked the last link, "Windows Assessment and Deployment Kit (ADK) for Windows 10" wich directs here: http://go.microsoft.com/fwlink/p/?LinkId=526740
I started the installer and chose to install the Compatibility Toolkit.

Really weird!

Back to top
View user's profile Send private message
Tuurngait



Joined: 07 Mar 2011
Posts: 299

PostPosted: Fri Dec 04, 2015 4:42 pm    Post subject: Reply with quote

That's really really strange now. I did the same way when downloading ACT.
Hmm ... but no matter which version it is. sdb files should be compatible.
Back to top
View user's profile Send private message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Fri Dec 04, 2015 11:13 pm    Post subject: Reply with quote

Ok let's wait the new IPL be released so that we can have more feedback.

Anyway, if I wanted to try your SDB, I'd simply have to create a database with all the fixes listed on the picture you posted, wouldn't I?

Thanks Martin, good night.
Back to top
View user's profile Send private message
Tuurngait



Joined: 07 Mar 2011
Posts: 299

PostPosted: Fri Dec 04, 2015 11:42 pm    Post subject: Reply with quote

Yes, exactly. First choose WinXP SP2, RunAsAdmin, HighDPIAware and ForceDXSetupSuccess fixes, then continue to the custom fixes and choose the ones showed on my picture.

I don't know whether an sdb is connected to an exe file via MD5/SHA1 checksum. Then it will only work with the 2014 enhanced exe.

Good night, my friend.
Back to top
View user's profile Send private message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Sat Dec 05, 2015 8:14 am    Post subject: Reply with quote

Tuurngait wrote:
I don't know whether an sdb is connected to an exe file via MD5/SHA1 checksum.


Hmm... interesting question.

My understanding is that it should not, unless you mark some of the checkboxes that appear at the last step of the SDB creation (size of the EXE, CRC etc.).

In fact, the XP Fix works with any version of Porsche.exe, because I tried almost all executables (I just missed the 2014 NoCD standard) and never had the CTD after the loading screen on Windows XP.

Thanks a lot for your time, suggestions and support.
Glad the PU community has a member like you.

Cya, Angel.
Back to top
View user's profile Send private message
Tuurngait



Joined: 07 Mar 2011
Posts: 299

PostPosted: Sat Dec 05, 2015 12:26 pm    Post subject: Reply with quote

Hey WhiteAngel,

I downloaded ACT again on my other Win10 computer and now I also have version 6.1 (exe file date is 23.10.2015). I checked the date from version 10.1 and it was older (July 2015). I don't know why there is such a big difference in version number. But 6.1 seems to be later somehow. So I'll create the sdb again and update my complete patch.

*edit
- New version is online. Please test if the new sdb works now for you.
Back to top
View user's profile Send private message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Sat Dec 05, 2015 5:11 pm    Post subject: Reply with quote

Tuurngait wrote:
I don't know why there is such a big difference in version number. But 6.1 seems to be later somehow.


Microsoft knows lol!
I also googled for ACT 10.1 but found nothing, and on all M$ sites it looks like the only download reported by now is the ADK with ACT6.1.

I guess they've removed all previous downloads, it happens frequently with ADKs especially now that it's all managed via a web installer.

Tuurngait wrote:
New version is online. Please test if the new sdb works now for you.


Wonderful!
Works like a charm now!!
Thanks man.
I'll have to send you a beer (shipping payment at my expense of course Very Happy )
Back to top
View user's profile Send private message
Tuurngait



Joined: 07 Mar 2011
Posts: 299

PostPosted: Sat Dec 05, 2015 6:25 pm    Post subject: Reply with quote

Haha, thanks Smile

Nice to hear. Seems that ACT 10.1 was part of the ADK for a very short time only. Maybe they decided to lower version number in later releases, because 6.1 makes more sense after 5.6.

Nice to have a working sdb now.


*edit 11.12.2015
I am working to update my complete patch with an even better sdb.
Back to top
View user's profile Send private message
[RS]nJL



Joined: 22 Jan 2015
Posts: 115
Location: Italy

PostPosted: Sat Dec 19, 2015 9:58 am    Post subject: Reply with quote

WhiteAngel wrote:
Tuurngait wrote:
I don't know whether an sdb is connected to an exe file via MD5/SHA1 checksum.

[...]
My understanding is that it should not, unless you mark some of the checkboxes that appear at the last step of the SDB creation (size of the EXE, CRC etc.).


I feel I can confirm this.
I tried your "old" SDB, the one you released with your first complete patch.
It works with Porsche.exe from 2012 (NoCD standard version), by now the latest supported by IPL.
No low polys at all, and I haven't had to set compatibility inside the EXE, neither!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    iplounge.net Forum Index -> IPL PU Support All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group